Welcome, Guest
Email: Password: Remember me

TOPIC: Good job TRP

Re: Good job TRP 1 year, 4 months ago #3026

I guess I'll have to pay more attention. I never heard about the $1 dogs. I definitely would have had a few. Marlow too! Seem's like David and the whole TRP are headed in the right direction. Sundays race was how they're suppose to be run. Quickly, without being rushed. A good flow of cars going down the track, the entire time. I should know I watched almost all of them from from the grandstands. I think it was a tree malfuntion, surely I wasn't Red. I swear, last three trips to the track, 3 tomato's. All 3 added together is only -.013. The track seemed to be iffy at times, the weather was not our friend. On the other hand, I matched my fasted pass ever. When it sticks, that track hauls-ass! The whole entry thing I think will be a good thing. Especially when you have a lot of cars. It always sucked to be stuck on the road forever, waiting to get in. Congrats to the winners, good job TRP!

Re: Good job TRP 1 year, 4 months ago #3027

Jeff, I probably heard the dollar dog announcement 20 times. Guess the ole hearing is starting to go. Of course I'm the same dummy that lost my fuel cell cap so what can I say about someone else.

Curtis

Re: Good job TRP 1 year, 4 months ago #3028

I hit that dollar dog deal harder than Joe Lewis hitting Frazier!

Re: Good job TRP 1 year, 4 months ago #3030

Shoot Curtis, the hearing went a long time ago. I do remember hearing it, now that I think about it. I was just too busy catching up with old friends. I'll do my best to make-em regret that decision next time around tho.

Re: Good job TRP 1 year, 4 months ago #3031

When I write a post. I see the edit button. After you hit Submit, it is still there. If you hit the edit tab. It doesn't edit, it just post. Does everyone else have this problem?

Re: Good job TRP 1 year, 4 months ago #3032

Jeff White wrote:
When I write a post. I see the edit button. After you hit Submit, it is still there. If you hit the edit tab. It doesn't edit, it just post. Does everyone else have this problem?


I don't see an edit button as I type this.. After I hit the submit button and it posts then an edit button shows up for a short period of time.. I've tried to use it before. I edit my post and hit submit and then get an error message that I don't have access to edit my post and it all goes back to the original.

Clicked edit and added this
Last Edit: 1 year, 4 months ago by Jon Hollis. Reason: added wording
Time to create page: 0.10 seconds